<!doctype html> <html amp lang="en"> <head> <meta charset="utf-8"> <meta name="viewport" content="width=device-width"> <meta name="theme-color" content="#E81B42"> <meta name="amp-ad-enable-refresh" content="network1=30"> <title>Ramarao On Duty Day 3 Box Office Collection Worldwide: Ravi Teja's Action Film Heads Towards A Flop! - Filmibeat</title> <meta name="news_keywords" content="ramarao on duty Day 3 box office collections, ramarao duty Day 3 box office collections worldwide, ramarao on duty worldwide box office collections Day 3, ramarao on duty Day 3 collections, ravi teja ramarao on duty box office day 3 collection, ramarao on duty collection worldwide, ramarao on duty  box office collection, raviteja ramarao on duty box office collection Day 3, ramarao on duty box office Day 3, raviteja ramarao on duty box office collection 3rd day"/> <meta name="description" content="Ramarao On Duty Day 3 Box Office Collection Worldwide: Ravi Teja&quot;s Action Film Heads Towards A Flop!"/> <meta property="taboola-category" content="english"/> <meta name="amp-google-client-id-api" content="googleanalytics"> <meta property="article:published_time" content="2022-08-01T10:01:38+05:30"/> <meta name="robots" content="max-image-preview:large"/> <meta property="article:modified_time" content="2022-08-01T10:42:16+05:30"/> <meta name="robots" content="index, follow"/> <link rel="canonical" href="https://www.filmibeat.com/telugu/news/2022/ramarao-on-duty-day-3-box-office-collection-worldwide-ravi-teja-s-action-film-heads-towards-a-flop-338544.html"/> <link as=script href="https://cdn.ampproject.org/v0.js" rel="preload"> <link rel="preconnect dns-prefetch" href="https://fonts.gstatic.com/" crossorigin> <link href="font.woff2" rel="preload"> <meta name="amp-consent-blocking" content="amp-ad"/> <script async custom-element="amp-consent" src="https://cdn.ampproject.org/v0/amp-consent-0.1.js"></script> <script async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script> <script async custom-element="amp-iframe" src="https://cdn.ampproject.org/v0/amp-iframe-0.1.js"></script> <script async custom-element="amp-fit-text" src="https://cdn.ampproject.org/v0/amp-fit-text-0.1.js"></script> <script async custom-element="amp-font" src="https://cdn.ampproject.org/v0/amp-font-0.1.js"></script> <script async custom-element="amp-lightbox" src="https://cdn.ampproject.org/v0/amp-lightbox-0.1.js"></script> <script async custom-element="amp-twitter" src="https://cdn.ampproject.org/v0/amp-twitter-0.1.js"></script> <script async custom-element="amp-analytics" src="https://cdn.ampproject.org/v0/amp-analytics-0.1.js"></script> <script async custom-element="amp-youtube" src="https://cdn.ampproject.org/v0/amp-youtube-0.1.js"></script> <script async custom-element="amp-carousel" src="https://cdn.ampproject.org/v0/amp-carousel-0.1.js"></script> <script async custom-element="amp-social-share" src="https://cdn.ampproject.org/v0/amp-social-share-0.1.js"></script> <script async custom-element="amp-sticky-ad" src="https://cdn.ampproject.org/v0/amp-sticky-ad-1.0.js"></script> <script async custom-element="amp-install-serviceworker" src="https://cdn.ampproject.org/v0/amp-install-serviceworker-0.1.js"></script> <script async custom-element="amp-dailymotion" src="https://cdn.ampproject.org/v0/amp-dailymotion-0.1.js"></script> <script async custom-element="amp-facebook" src="https://cdn.ampproject.org/v0/amp-facebook-0.1.js"></script> <script async src="https://cdn.ampproject.org/v0.js"></script> <script async custom-element="amp-auto-ads" src="https://cdn.ampproject.org/v0/amp-auto-ads-0.1.js"></script> <script async custom-element="amp-fx-flying-carpet" src="https://cdn.ampproject.org/v0/amp-fx-flying-carpet-0.1.js"></script> <link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans:300,400,600,700&display=swap"> <link href="https://fonts.googleapis.com/icon?family=Material+Icons&display=swap" rel="stylesheet" type="text/css"/> <script async custom-element="amp-instagram" src="https://cdn.ampproject.org/v0/amp-instagram-0.1.js"></script> <script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage":{
    "@type":"WebPage",
    "@id":"https://www.filmibeat.com/telugu/news/2022/ramarao-on-duty-day-3-box-office-collection-worldwide-ravi-teja-s-action-film-heads-towards-a-flop-338544.html"
  },
  "headline": "Ramarao On Duty Day 3 Box Office Collection Worldwide: Ravi Teja&amp;#39;s Action Film Heads Towards A Flop!",
  "image": {
    "@type": "ImageObject",
    "url": ["https://www.filmibeat.com/img/2022/08/rodrt-1659328269.jpg","https://www.filmibeat.com/img/2022/08/06-1659328260.jpg"],
     "width": 696,
    "height": 450
  },
  "datePublished": "2022-08-01T10:01:38+05:30",
  "dateModified": "2022-08-01T10:42:16+05:30",
  "author": {
    "@type": "Person",
    "url": "https://www.filmibeat.com/authors/ChSowmyaSruthi.html",
    "name": "Ch Sowmya Sruthi"
  },
   "publisher": {
    "@type": "Organization",
    "name": "Filmibeat",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.filmibeat.com/images/amp-filmibeat-logo.png",
      "width": 225,
      "height": 60
    }
  },
   "description": "Ramarao On Duty Day 3 Box Office Collection Worldwide: Ravi Teja&quot;s Action Film Heads Towards A Flop!",
   "keywords": "Ramarao on duty Day 3 box office collections, ramarao duty Day 3 box office collections worldwide, ramarao on duty worldwide box office collections Day 3, ramarao on duty Day 3 collections, ravi teja ramarao on duty box office day 3 collection, ramarao on duty collection worldwide, ramarao on duty  box office collection, raviteja ramarao on duty box office collection Day 3, ramarao on duty box office Day 3, raviteja ramarao on duty box office collection 3rd day",
   "articleBody":"Ramarao On Duty, Massraja Ravi Tejas latest action film under the direction of Sarath Mandava opened to a divided talk on July 29 all over the world. The movie, which secured a negative word-of-mouth, is heading towards a flop.Ravi Teja portrayed the role of an honest civil servant in the film, who gets posted in the Chittoor region. He stumbles across a few unsolved mysterious murder cases and entangled in the smuggling racket lead by the antagonists. He locks horns with the villains.Take a look at Ramarao On Duty Day 3 Box Office Collection:Nizam: 1.21 CroreCeeded: 64 LakhUA: 54 LakhEast: 37 LakhWest: 20 LakhGuntur: 31 LakhKrishna: 23 LakhNellore: 15 LakhAP-TG Total: 3.65 Crore(6.15 Crore #126; Gross)KA+ ROI: 0.30 CroreOS: 43 LakhTotal World Wide: 4.38 Crore(7.60Crore #126; Gross)Divyansha Kaushik and Rajisha Vijayan are in the film as the female leads. Actors like Nassar, Naresh, Pavitra Lokesh, John Vijay, Chaitanya Krishna, Surekha Vani, Tanikella Bharani, and Rahul Ramakrishna are part of Ramarao On Duty.Ramarao On Duty is produced collectively by Ravi Tejas RT Team Works and Sri Venkateswara Cinemas. The technical crew include Sam CS for the music, Sathyan Sooryan for cinematography, and Praveen KL for editing."
}
</script> <script type="application/ld+json">
   {"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https:\/\/www.filmibeat.com"},{"@type":"ListItem","position":2,"name":"telugu","item":"https:\/\/www.filmibeat.com\/telugu\/"},{"@type":"ListItem","position":3,"name":"news","item":"https:\/\/www.filmibeat.com\/telugu\/news\/"}]}
</script> <style amp-boilerplate>body{-webkit-animation:-amp-start 8s steps(1,end) 0s 1 normal both;-moz-animation:-amp-start 8s steps(1,end) 0s 1 normal both;-ms-animation:-amp-start 8s steps(1,end) 0s 1 normal both;animation:-amp-start 8s steps(1,end) 0s 1 normal both}@-webkit-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@-moz-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@-ms-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@-o-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}</style><noscript><style amp-boilerplate>body{-webkit-animation:none;-moz-animation:none;-ms-animation:none;animation:none}</style></noscript> <style amp-custom>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</style> </head> <body class="miniopera"> <amp-consent id="googlefc" layout="nodisplay" type="googlefc"> <script type="application/json">
{
    "clientConfig":{
        "publisherIdentifier":"pub-6601380052549923"
    }
}
</script> </amp-consent> <amp-iframe title="User Sync" width=1 height=1 sandbox="allow-same-origin allow-scripts" frameborder="0" src="https://ads.pubmatic.com/AdServer/js/pwtSync/load-cookie.html?pubid=161067&profid=5274&bidders=appnexus,pubmatic,aol,rubicon,ix,openx"> <amp-img layout="fill" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" placeholder></amp-img> </amp-iframe> <div id="wrapper" data-slideshow="false"> <amp-install-serviceworker src="/oiframework-sw.js?v=1.0.5" data-iframe-src="https://www.filmibeat.com/oiframework-sw.html" layout="nodisplay"> </amp-install-serviceworker> <amp-analytics type="googleanalytics" id="analytics1"> <script type="application/json">
{
  "requests": {
    "pageviewWithCDs": "${pageview}&cd1=${cd1}" 
    },
  "vars": {
    "account": "UA-110466-50"    
  },
  "extraUrlParams": {
        "cd1": "oi-Ch Sowmya Sruthi",
       "cd2": "AMP",
    "cd3": "2022-08-01",
    "cd4": "https://www.filmibeat.com/telugu/news/2022/ramarao-on-duty-day-3-box-office-collection-worldwide-ravi-teja-s-action-film-heads-towards-a-flop-338544.html",
    "cd8": "article-amp"
  },
  "triggers": {
    "trackPageviewWithCustom" : {   
      "on": "visible",
      "request": "pageviewWithCDs",
      "vars": {
            "cd1": "oi-Ch Sowmya Sruthi",
            "cd3": "2022-08-01",
      "cd4": "https://www.filmibeat.com/telugu/news/2022/ramarao-on-duty-day-3-box-office-collection-worldwide-ravi-teja-s-action-film-heads-towards-a-flop-338544.html",
      "cd8": "article-amp"
      }
    }
  }
}
</script> </amp-analytics> <amp-analytics type="googleanalytics" id="analytics2"> <script type="application/json">
{
  "vars": {
    "account": "UA-110466-47"  
  },
  "triggers": {
    "trackPageviewChild": { 
      "on": "visible",
      "request": "pageview"
    }
  }
}
</script> </amp-analytics> <amp-analytics type="comscore"> <script type="application/json">
{
  "vars": {
    "c2": "7732551",
    "c1": "2"
  }
}
</script> </amp-analytics> <header> <div id="mobi-header"> <div class="mobi-navigation"> <div id="mobi-menu"> <div class="menu-links"> <button class="mainmenu_open" on="tap:mainmenu_lightbox" title="menu"> <span></span> <span></span> <span></span> </button> <amp-lightbox id="mainmenu_lightbox" layout="nodisplay"> <button on="tap:mainmenu_lightbox.close" class="mainmenu_close" title="menu"> <span></span> <span class="secondspan"></span> <span></span> </button> <div id="mainMenu" class="mobi-primary-nav"> <ul> <li class="mainnav"> <a href="/" class="submenu"><span>Home</span></a> </li> <li class="mainnav clearfix"> <a href="/bollywood/" class="submenu mainnav-subnav"><span>Bollywood</span></a> </li> <li class="mainnav clearfix"> <a href="/bollywood/news/" class="submenu mainnav-subnav"><span>News</span></a> </li> <li class="mainnav clearfix"> <a href="/bollywood/gupshup/" class="submenu mainnav-subnav"><span>Gossip</span></a> </li> <li class="mainnav clearfix"> <a href="/bollywood/features/" class="submenu mainnav-subnav"><span>Feature</span></a> </li> <li class="mainnav clearfix"> <a href="/bollywood/reviews/" class="submenu mainnav-subnav"><span>Review</span></a> </li> <li class="mainnav clearfix"> <a href="/bollywood/box-office/" class="submenu mainnav-subnav"><span>Box Office</span></a> </li> <li class="mainnav clearfix"><a href="/peep/" class="submenu mainnav-subnav"><span>Peep</span></a></li> <li class="mainnav clearfix"> <a href="/movies.html" class="submenu mainnav-subnav moviespromo"><span>Movies</span></a> </li> <li class="mainnav clearfix"> <a href="https://www.filmibeat.com/photos/" class="submenu mainnav-subnav"><span>Photos</span></a> </li> <li class="mainnav clearfix"> <a href="/videos/" class="submenu mainnav-subnav"><span>Videos </span></a> </li> <li class="mainnav clearfix"> <a href="/celebs/" class="submenu mainnav-subnav"><span>Celebs</span></a> </li> <li class="mainnav clearfix"> <a href="/tamil/" class="submenu mainnav-subnav"><span>Tamil</span></a> </li> <li class="mainnav clearfix"> <a href="/telugu/" class="submenu mainnav-subnav"><span>Telugu</span></a> </li> <li class="mainnav clearfix"> <a href="/malayalam/" class="submenu mainnav-subnav"><span>Malayalam</span></a> </li> <li class="mainnav clearfix"> <a href="/kannada/" class="submenu mainnav-subnav"><span>Kannada</span></a> </li> </ul> </div> </amp-lightbox> </div> <div class="mobi-logo"> <a href="https://www.filmibeat.com/"><amp-img data-hero src="/images/filmibeat-logo-1.svg" alt="Filmibeat" height="28" width="100"></amp-img></a> </div> </div> </div> <div class="clear"></div> <div class="kan-filmi-homemenu menu-wrapper"> <ul class="menu"> <li class="item"> <a href="/bollywood/" class="active">Bollywood</a> </li><li class="item"> <a href="/topic/bigg-boss/?ref_source=FB-EN&amp;ref_medium=mobile&amp;ref_campaign=bb14-header">Bigg Boss</a> </li> <li class="item"> <a href="/movies.html">Movies </a> </li> <li class="item"> <a href="/videos">Videos </a> </li> <li class="item"> <a href="/celebs/">Celebs </a> </li> <li class="item"> <a href="/television/news/">TV </a> </li> <li class="item"> <a href="/photos">Photos</a> </li> <li class="item"> <a href="/bollywood/box-office/">Box Office</a> </li> <li class="item"> <a href="/telugu/">Telugu</a> </li> <li class="item"> <a href="/tamil/">Tamil</a> </li> <li class="item"> <a href="/malayalam/">Malayalam</a> </li> <li class="item"> <a href="/kannada/">Kannada</a> </li> <li class="item"> <a href="/hollywood/">Hollywood </a> </li> <li class="item"> <a href="/top-listing/">Top Listing</a> </li> <li class="item"> <a href="/wallpapers/">Wallpapers </a> </li> <li class="item"> <a href="https://www.filmibeat.com/trending-videos/?ref=title">Trending Videos</a> </li> </ul> </div> </div> </header> </div> <div id="containerMain" class="clearfix"> <section> <div id="container" data-content_id="338544" data-slideshow="false" data-category_name="telugu" data-category_id="186"> <section> <article> <div id="inner-article-wrapper"> <div class="breadcrumb"> <nav> <a href="/">Home</a> <span>&raquo;</span> <a href="/telugu/">Telugu</a> <span>&raquo;</span> <a href="/telugu/news/">News</a> </nav> </div> <header> <h1 class="oneindia-article-heading" itemprop="headline">Ramarao On Duty Day 3 Box Office Collection Worldwide: Ravi Teja's Action Film Heads Towards A Flop!</h1> <div class="datetime date-time"> <h3 itemprop="author" itemscope itemtype="https://schema.org/Person"> <span itemprop="name" class="author-profile posted-by"><div class="author-profile written-by">By <a rel="author" href="/authors/ChSowmyaSruthi.html" title="Profile of Ch Sowmya Sruthi" target="_blank"><strong>Ch Sowmya Sruthi</strong></a></div></span> </h3> </br> <time datetime="2022-08-01T10:42:16+05:30" itemprop="dateModified">
Updated: Monday, August 1, 2022, 10:42 [IST]
</time> </div> <div class="socialshare"> <amp-social-share type="facebook" class="share-links" data-param-app_id="1528152444062893" width="30px" height="30px"></amp-social-share> <amp-social-share type="twitter" class="share-links" width="30px" height="30px"></amp-social-share> <amp-social-share type="whatsapp" class="share-links" width="30px" height="30px"></amp-social-share> </div> <div id="first-ad"> <span class="oiad-txt">Advertisement</span> <div class='ampinnerad'> <amp-ad width=300 height=250 type="doubleclick" data-slot="/1008496/fb-eng-inarticle-300x250-mobi-1" data-multi-size="300x250,320x50" json='{"targeting":{"device_type":["amp"],"domain":["filmibeat.com"],"page":["fben-article-amp"],"lang":["EN"]}}' rtc-config='{
        "vendors": {
           "openwrap": {
             "PROFILE_ID" : "5274",
             "PUB_ID" : "161067"
           }
         },
         "timeoutMillis": 1000
        }' data-enable-refresh=30> </amp-ad> </div> </div> </header> <div id="story" class="story"> <div id="article-content-div"> <p>Ramarao On Duty, Massraja Ravi Teja's latest action film under the direction of Sarath Mandava opened to a divided talk on July 29 all over the world. The movie, which secured a negative word-of-mouth, is heading towards a flop.</p><p><strong></div><div class="article_image"><div class="big-center-img" data-cl-cnt="1" data-cnt-t="0" data-gal-src="https://www.filmibeat.com/img/2022/08/06-1659328260.jpg"><div class="left"><a href="#"><div><amp-img data-hero width="600" height="338" src="https://www.filmibeat.com/img/2022/08/06-1659328260.jpg" alt="Ramarao On Duty Day 3 Box Office Collection" title="Ramarao On Duty Day 3 Box Office Collection" data-qimg="https://www.filmibeat.com/img/2022/08/06-1659328260.jpg" data-cl-slideshow="" data-cl-title="Ramarao On Duty Day 3 Box Office Collection" data-cl-description="" data-cl-imageid="338544-1" class="contain" layout="responsive"></amp-img></div></a></div></div></div><div class="article_middle"></strong></p><p>Ravi Teja portrayed the role of an honest civil servant in the film, who gets posted in the Chittoor region. He stumbles across a few unsolved mysterious murder cases and entangled in the smuggling racket lead by the antagonists. He locks horns with the villains.</p><div class='amp-inner-ad'><amp-ad width='320' height='250' type='doubleclick' data-slot='/1008496/fb-eng-inarticle-300x250-mobi-2' data-multi-size='300x250,320x50' json='{"targeting":{"device_type":["amp"],"domain":["filmibeat.com"],"page":["fben-article-amp"],"lang":["EN"]}}' rtc-config='{"vendors":{"openwrap":{"PROFILE_ID":"5274","PUB_ID":"161067"}},"timeoutMillis":1000}' data-multi-size-validation='false' data-enable-refresh='30'></amp-ad></div><p><strong><div class="big-center-img" data-cl-cnt="0" data-cnt-t="1" data-gal-src="https://www.filmibeat.com/img/2022/08/rodrt-1659328269.jpg"><div class="left"><a href="#"><div><amp-img data-hero width="600" height="338" src="https://www.filmibeat.com/img/2022/08/rodrt-1659328269.jpg" alt="Ramarao On Duty Day 3 Box Office Collection" title="Ramarao On Duty Day 3 Box Office Collection" data-qimg="https://www.filmibeat.com/img/2022/08/rodrt-1659328269.jpg" data-cl-slideshow="" data-cl-title="Ramarao On Duty Day 3 Box Office Collection" data-cl-description="" data-cl-imageid="338544-0" class="contain" layout="responsive"></amp-img></div></a></div></div></strong></p><div class="amp-flying-carpet"><div class="amp-flying-carpet-text-border">Advertisement</div><amp-fx-flying-carpet height="400px"> <amp-ad width="300" height="600" type="doubleclick" data-slot="/1008496/fb-carpet-amp" data-multi-size="300x600" layout="fixed" rtc-config={"vendors":{"openwrap":{"PROFILE_ID":"5274","PUB_ID":"161067"}},"timeoutMillis":1000} json={"targeting":{"device_type":["amp"],"tcpt":"TCPT_NL","domain":["filmibeat.com"],"page":["fben-article-amp"],"lang":["EN"]}} data-enable-refresh=30> </amp-ad> </amp-fx-flying-carpet> <div class="amp-flying-carpet-text-border">Advertisement</div></div><p>Take a look at <strong>Ramarao On Duty Day 3 Box Office Collection:</strong></p><p>Nizam: 1.21 Crore<br>Ceeded: 64 Lakh<br>UA: 54 Lakh<br>East: 37 Lakh<br>West: 20 Lakh<br>Guntur: 31 Lakh<br>Krishna: 23 Lakh<br>Nellore: 15 Lakh<br><strong>AP-TG Total: 3.65 Crore(6.15 Crore&#126; Gross)</strong></p><p>KA+ ROI: 0.30 Crore<br>OS: 43 Lakh<br><strong>Total World Wide: 4.38 Crore(7.60Crore&#126; Gross)</strong></p><p>Divyansha Kaushik and Rajisha Vijayan are in the film as the female leads. Actors like Nassar, Naresh, Pavitra Lokesh, John Vijay, Chaitanya Krishna, Surekha Vani, Tanikella Bharani, and Rahul Ramakrishna are part of Ramarao On Duty.</p><p>Ramarao On Duty is produced collectively by Ravi Teja's RT Team Works and Sri Venkateswara Cinemas. The technical crew include Sam CS for the music, Sathyan Sooryan for cinematography, and Praveen KL for editing.</p><div id="inread"></div><div class="content_comments" id="content_comments"></div><div id='moviesconnector'></div><div></div><amp-iframe width=100 height=100 layout="responsive" sandbox="allow-popups allow-scripts allow-same-origin" src="https://www1.filmibeat.com/scripts/photos/embed-photos-iframe-new.php?tags=ravi teja, ramarao on duty, sarath mandava, divyansha kaushik, rajisha vijayan, venu thottempudi&category_type=telugu"> </amp-iframe><div class="amp-inner-ad gap15"> <span class="oiad-txt1">Advertisement</span> <amp-ad width=336 height=280 type="doubleclick" data-slot="/21622890900,1008496/SG_Filmibeat.com_amp_article_mid2_300x250//336x280" data-multi-size="300x250" data-multi-size-validation="false"> </amp-ad> </div> <section> <div class="filmibeat-section"> <div class="filmibeat-morenews-block"> <div class="filmibeat-section-heading"><a href="/topic/ravi-teja/?ref_medium=AMP&ref_source=FB-EN&ref_campaign=Similar-Topic">MORE<span>RAVI TEJA</span>NEWS </a> </div> <div class="filmibeat-videoslist morenews"> <ul> <li> <a href="/telugu/news/2022/ramarao-on-duty-day-2-box-office-collection-worldwide-the-film-is-a-forgettable-one-for-ravi-teja-338510.html?ref_medium=AMP&ref_source=FB-EN&ref_campaign=Similar-Topic-Slider"> <div class="filmibeat-videos-thumbimg"> <amp-img src="https://www.filmibeat.com/img/210x85x118/2022/07/ramarao-1659181452.jpg" width="210" height="118" layout="responsive"></amp-img> </div> <div class="filmibeat-videos-title boxoffice-title">Ramarao On Duty Day 2 Box Office Collection Worldwide: The Film Is A Forgettable One For Ravi Teja!</div> </a> </li> <li> <a href="/telugu/news/2022/ramarao-on-duty-day-1-box-office-collection-worldwide-ravi-teja-s-action-film-opens-to-divided-resp-338454.html?ref_medium=AMP&ref_source=FB-EN&ref_campaign=Similar-Topic-Slider"> <div class="filmibeat-videos-thumbimg"> <amp-img src="https://www.filmibeat.com/img/210x85x118/2022/07/0-1659083939.jpg" width="210" height="118" layout="responsive"></amp-img> </div> <div class="filmibeat-videos-title boxoffice-title">Ramarao On Duty Day 1 Box Office Collection Worldwide: Ravi Teja's Action Film Opens To Divided Response</div> </a> </li> <li> <a href="/telugu/news/2022/ramarao-on-duty-twitter-review-check-out-what-twitterati-have-to-say-about-ravi-teja-s-latest-flick-338406.html?ref_medium=AMP&ref_source=FB-EN&ref_campaign=Similar-Topic-Slider"> <div class="filmibeat-videos-thumbimg"> <amp-img src="https://www.filmibeat.com/img/210x85x118/2022/07/ramarao-1658995089.jpg" width="210" height="118" layout="responsive"></amp-img> </div> <div class="filmibeat-videos-title boxoffice-title">Ramarao On Duty Twitter Review: Check Out What Twitterati Have To Say About Ravi Teja's Latest Flick!</div> </a> </li> <li> <a href="/telugu/news/2022/ramarao-on-duty-first-review-mass-raja-ravi-teja-s-action-entertainer-is-purely-made-for-fans-338404.html?ref_medium=AMP&ref_source=FB-EN&ref_campaign=Similar-Topic-Slider"> <div class="filmibeat-videos-thumbimg"> <amp-img src="https://www.filmibeat.com/img/210x85x118/2022/07/1-1658993048.jpg" width="210" height="118" layout="responsive"></amp-img> </div> <div class="filmibeat-videos-title boxoffice-title">Ramarao On Duty First Review: Mass Raja Ravi Teja's Action Entertainer Is Purely Made For Fans!</div> </a> </li> <li> <a href="/telugu/news/2022/ramarao-on-duty-pre-release-business-worldwide-ravi-teja-s-upcoming-action-film-made-this-much-338300.html?ref_medium=AMP&ref_source=FB-EN&ref_campaign=Similar-Topic-Slider"> <div class="filmibeat-videos-thumbimg"> <amp-img src="https://www.filmibeat.com/img/210x85x118/2022/07/ramarao-1658824637.jpg" width="210" height="118" layout="responsive"></amp-img> </div> <div class="filmibeat-videos-title boxoffice-title">Ramarao On Duty Pre-Release Business Worldwide</div> </a> </li> <li> <a href="/telugu/news/2022/mega-154-ravi-teja-opts-out-of-chiranjeevi-s-film-citing-date-issues-makers-on-a-hunt-for-another-a-337443.html?ref_medium=AMP&ref_source=FB-EN&ref_campaign=Similar-Topic-Slider"> <div class="filmibeat-videos-thumbimg"> <amp-img src="https://www.filmibeat.com/img/210x85x118/2022/07/1-1657353994.jpg" width="210" height="118" layout="responsive"></amp-img> </div> <div class="filmibeat-videos-title boxoffice-title">Mega 154: Ravi Teja Opts Out Of Chiranjeevi's Film Citing Date Issues;Makers On A Hunt For Another Actor!</div> </a> </li> <li> <a href="/telugu/news/2022/tiger-nageswara-rao-gayatri-bharadwaj-comes-on-board-for-ravi-teja-starrer-332328.html?ref_medium=AMP&ref_source=FB-EN&ref_campaign=Similar-Topic-Slider"> <div class="filmibeat-videos-thumbimg"> <amp-img src="https://www.filmibeat.com/img/210x85x118/2022/04/tnr-1648810491.jpg" width="210" height="118" layout="responsive"></amp-img> </div> <div class="filmibeat-videos-title boxoffice-title">Tiger Nageswara Rao: Gayatri Bharadwaj Comes On Board For Ravi Teja Starrer</div> </a> </li> <li> <a href="/telugu/news/2022/ramarao-on-duty-songs-of-ravi-teja-starrer-to-be-shot-in-spain-330977.html?ref_medium=AMP&ref_source=FB-EN&ref_campaign=Similar-Topic-Slider"> <div class="filmibeat-videos-thumbimg"> <amp-img src="https://www.filmibeat.com/img/210x85x118/2022/03/raviteja-1646740691.jpg" width="210" height="118" layout="responsive"></amp-img> </div> <div class="filmibeat-videos-title boxoffice-title">Ramarao On Duty: Songs Of Ravi Teja Starrer To Be Shot In Spain</div> </a> </li> <li> <a href="/telugu/news/2022/khiladi-ott-release-date-and-timings-details-on-disney-hotstar-is-here-330778.html?ref_medium=AMP&ref_source=FB-EN&ref_campaign=Similar-Topic-Slider"> <div class="filmibeat-videos-thumbimg"> <amp-img src="https://www.filmibeat.com/img/210x85x118/2022/02/khiladi-1644496222.jpg" width="210" height="118" layout="responsive"></amp-img> </div> <div class="filmibeat-videos-title boxoffice-title">Khiladi OTT Release Date And Timings On Disney + Hotstar Is Here! </div> </a> </li> <li> <a href="/telugu/news/2022/khiladi-day-3-box-office-collection-here-s-how-much-ravi-teja-s-film-has-fared-so-far-329691.html?ref_medium=AMP&ref_source=FB-EN&ref_campaign=Similar-Topic-Slider"> <div class="filmibeat-videos-thumbimg"> <amp-img src="https://www.filmibeat.com/img/210x85x118/2022/02/ravitejainkhiladi-1644817458.jpg" width="210" height="118" layout="responsive"></amp-img> </div> <div class="filmibeat-videos-title boxoffice-title">Khiladi Day 3 Box Office Collection: Here’s How Much Ravi Teja’s Film Has Fared So Far!</div> </a> </li> <li> <a href="/telugu/news/2022/khiladi-day-2-box-office-collection-ravi-teja-s-film-is-unstoppable-329607.html?ref_medium=AMP&ref_source=FB-EN&ref_campaign=Similar-Topic-Slider"> <div class="filmibeat-videos-thumbimg"> <amp-img src="https://www.filmibeat.com/img/210x85x118/2022/02/khiladi-1644647932.jpg" width="210" height="118" layout="responsive"></amp-img> </div> <div class="filmibeat-videos-title boxoffice-title">Khiladi Day 2 Box Office Collection: Ravi Teja's Film Is Unstoppable!</div> </a> </li> <li> <a href="/telugu/news/2022/khiladi-day-1-box-office-collection-a-fiery-start-for-ravi-teja-starrer-329591.html?ref_medium=AMP&ref_source=FB-EN&ref_campaign=Similar-Topic-Slider"> <div class="filmibeat-videos-thumbimg"> <amp-img src="https://www.filmibeat.com/img/210x85x118/2022/02/khiladi-1644606086.jpg" width="210" height="118" layout="responsive"></amp-img> </div> <div class="filmibeat-videos-title boxoffice-title">Khiladi Day 1 Box Office Collection: A Fiery Start For Ravi Teja Starrer!</div> </a> </li> </ul> </div> <div class="filmibeat-more-articles"> <a href="/topic/ravi-teja/?ref_medium=AMP&ref_source=FB-EN&ref_campaign=Similar-Topic"><i class="fa fa-plus-circle"></i></a></div> </div> </div> </section><amp-iframe width=100 height=80 layout="responsive" sandbox="allow-popups allow-scripts allow-same-origin" src="https://www1.filmibeat.com/scripts/popcorn/cron-jobs/trending_movies_celebs_article_feed_amp_iframe.php?tags=ravi teja, ramarao on duty, sarath mandava, divyansha kaushik, rajisha vijayan, venu thottempudi&cat_name=telugu"> </amp-iframe><div class='article_middle'><div class="tags_content" id="tags_container"><div class="tags clearfix"><span class="tags_head">Read More About: </span> <a title="ravi teja" href="/topic/ravi-teja">#ravi teja</a> <a title="ramarao on duty" href="/topic/ramarao-on-duty">#ramarao on duty</a> <a title="sarath mandava" href="/topic/sarath-mandava">#sarath mandava</a> <a title="divyansha kaushik" href="/topic/divyansha-kaushik">#divyansha kaushik</a> </div></div> <div class="tags_content"></div></div></p> </div> </div> </div> </article> </section> <div id="mobifooterad"> <amp-ad width=320 height=250 type="doubleclick" data-slot="/1008496/AMP-320x250" data-multi-size="320x250" data-enable-refresh=30 data-multi-size-validation="false" rtc-config='{
        "vendors": {
           "openwrap": {
             "PROFILE_ID" : "5274",
             "PUB_ID" : "161067"
           }
         },
         "timeoutMillis": 1000
        }' json='{"targeting":{"device_type":["amp"],"domain":["filmibeat.com"],"page":["fben-article-amp"],"lang":["EN"]}}'> </amp-ad> </div> <amp-embed width=100 height=100 type=taboola layout=responsive data-publisher='oneindiadigital-filmibeat' data-mode='thumbs-feed-01-a' data-placement='Below Article Thumbnails AMP' data-target_type='mix' data-article='auto' data-feed-container-num="1" data-url='https://www.filmibeat.com/telugu/news/2022/ramarao-on-duty-day-3-box-office-collection-worldwide-ravi-teja-s-action-film-heads-towards-a-flop-338544.html'> </amp-embed> <div class="amp-inner-ad"> <center> <amp-ad width="336" height="280" type="doubleclick" data-slot="/213794966,1008496/amp/www.filmibeat.com" data-enable-refresh="30" data-multi-size="1x1,320x100,320x50,300x250,336x280" rtc-config='{"urls":[https://pb.vuukle.com/openrtb2/amp?tag_id=www.filmibeat.com&w=ATTR(width)&h=ATTR(height)&ow=ATTR(data-override-width)&oh=ATTR(data-override-height)&ms=ATTR(data-multi-size)&slot=ATTR(data-slot)&targeting=TGT&curl=CANONICAL_URL&timeout=TIMEOUT&adcid=ADCID&purl=HREF]}'> </amp-ad> <amp-iframe width="1" title="User Sync" height="1" sandbox="allow-scripts allow-same-origin" frameborder="0" src="https://pb.vuukle.com/load-cookie-with-consent.html?max_sync_count=50&defaultGdprScope=0"> <amp-img layout="fill" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" placeholder></amp-img> </amp-iframe> </center> </div> <amp-embed width=100 height=100 type=taboola layout=responsive data-publisher='oneindiadigital-filmibeat' data-mode='thumbs-feed-01-a' data-placement='Below Article Thumbnails AMP' data-target_type='mix' data-article='auto' data-feed-container-num="2" data-url='https://www.filmibeat.com/telugu/news/2022/ramarao-on-duty-day-3-box-office-collection-worldwide-ravi-teja-s-action-film-heads-towards-a-flop-338544.html'> </amp-embed> <div class="vuukdiv"> <amp-iframe title="vuukle" width=600 height=140 layout="responsive" sandbox="allow-scripts allow-same-origin allow-modals allow-popups allow-forms" resizable frameborder="0" src="https://cdn.vuukle.com/amp.html?url=https://www.filmibeat.com/telugu/news/2022/ramarao-on-duty-day-3-box-office-collection-worldwide-ravi-teja-s-action-film-heads-towards-a-flop-338544.html&host=www.filmibeat.com&id=338544&apiKey=32ea1377-42f8-49bd-a80b-5a3bf4466257&transliterationLanguage=en&title=Ramarao On Duty Day 3 Box Office Collection Worldwide: Ravi Teja&amp;#39;s Action Film Heads Towards A Flop!"> <div overflow tabindex=0 role=button aria-label="">Read more...</div> </amp-iframe> </div> <div class="amp-inner-ad"> <amp-ad width=300 height=250 type="doubleclick" data-slot="/1008496/vuukle-comments-300x250" data-multi-size="300x250" data-multi-size-validation="false" rtc-config='{
        "vendors": {
           "openwrap": {
             "PROFILE_ID" : "5274",
             "PUB_ID" : "161067"
           }
         },
         "timeoutMillis": 1000
        }' json='{"targeting":{"device_type":["amp"],"domain":["filmibeat.com"],"page":["fben-article-amp"],"lang":["EN"]}}' data-enable-refresh=30> </amp-ad> </div> <amp-embed width=100 height=100 type=taboola layout=responsive data-publisher='oneindiadigital-filmibeat' data-mode='thumbs-feed-01-a' data-placement='Below Article Thumbnails AMP' data-target_type='mix' data-article='auto' data-feed-container-num="3" data-url='https://www.filmibeat.com/telugu/news/2022/ramarao-on-duty-day-3-box-office-collection-worldwide-ravi-teja-s-action-film-heads-towards-a-flop-338544.html'> </amp-embed> <section> </section> <amp-embed width=100 height=100 type=taboola layout=responsive data-publisher='oneindiadigital-filmibeat' data-mode='thumbs-feed-01-a' data-placement='Below Article Thumbnails AMP' data-target_type='mix' data-article='auto' data-feed-container-num="4" data-url='https://www.filmibeat.com/telugu/news/2022/ramarao-on-duty-day-3-box-office-collection-worldwide-ravi-teja-s-action-film-heads-towards-a-flop-338544.html'> </amp-embed> </div> </section> </div> <amp-auto-ads type="adsense" data-ad-client="ca-pub-6601380052549923"> </amp-auto-ads> <amp-sticky-ad layout="nodisplay"> <amp-ad width="320" height="50" type="doubleclick" data-slot="/1008496/fb-320x50" json='{"targeting":{"device_type":["amp"],"domain":["filmibeat.com"],"page":["fben-article-amp"],"lang":["EN"]}}' data-multi-size="320x50" data-enable-refresh="30" rtc-config='{
        "vendors": {
           "openwrap": {
             "PROFILE_ID" : "5274",
             "PUB_ID" : "161067"
           }
         },
         "timeoutMillis": 1000
        }'> </amp-ad> </amp-sticky-ad> </div> <footer id="footer"> <div id="footerMain"> <div class="site-footer-block"> <div class="footer-links"> <a href="https://www.filmibeat.com/aboutus.html">About</a><span>•</span><a href="https://www.greynium.com/terms-of-service" rel="nofollow">Terms of Service</a><span>•</span><a href="https://www.greynium.com/privacy-policy" rel="nofollow">Privacy Policy</a><span>&bull;</span> <a href="/common/cookies/mobi/change-cookie-settings.html" target="_blank" rel="nofollow">Cookie Policy</a><span>•</span><a href="https://www.filmibeat.com/contact.html">Contact</a> </div> <div class="copyright-text">&copy; 2022 Greynium Information Technologies Pvt. Ltd.</div> </div> </div> </footer> </body> </html>